Archive for the ‘Cisco’ Category

Konfigurasi Cisco Catalyst

Posted: Agustus 24, 2010 in Cisco
Tag:, , ,

Konfigurasinya adalah :

Sebelum mengkonfigurasi Catalyst, yang musti disediain adalah sebuah komputer, atau laptop dengan port COM, kabel Console, dan sebuah program Hyper Terminal. Kalo laptop yang anda punya nggak punya port COM, berarti anda musti punya kabel converter dari COM (db-9)

Langkah selanjutnya adalah menghubungkan kabel Console ke port COM komputer dan port Console Catalyst. Tentunya komputer dan Catalyst harus udah terhubung ke power supply. Oke, selanjutnya buka hyper terminal. Pilih nama port yang dipake buat terhubung ke Catalyst. Bikin speed rate nya jadi 9600. Nah, Catalyst sudah siap di konfigurasi.

Setting Password
router>enable
router#configure terminal
router(config)#enable password password
router(config)#enable secret secret

Setting Host Name
router>enable
router#configure terminal
router(config)#hostname nama-host

Setting Vlan
router>enable
router#configure terminal
router(config)#vlan nomor-vlan
router(config-vlan)#name nama-vlan

Setting IP Address pada Vlan
router>enable
router#configure terminal
router(config)#interface vlan 1
router(config-if)#ip address address mask
router(config-if)#no shutdown

Setting Identitas pada Port

router>enable
router#configure terminal
router(config)#interface nama-port
router(config-if)#description “Uplink ke PPSI”
router(config-if)#end

Setting IP Gateway
router>enable
router#configure terminal
router(config)#ip default-gateway address

Setting Port-Speed dan Link-Mode
router#configure terminal
router(config)#interface nama-port
router(config-if)#speed 100
router(config-if)#duplex full

router#configure terminal
router(config)#interface nama-port
router(config-if)#switchport mode access
router(config-if)#switchport access vlan nama-vlan

router#configure terminal
router(config)#interface nama-port
router(config-if)#switchport mode trunk
router(config-if)#switchport trunk allowed vlan nama-vlan

Setting Line VTY ( remote telnet )
router#configure terminal
router(config)#line vty 0 4
router(config-line)#login
router(config-line)#password password

Setting Line Con 0
router#configure terminal
router(config)#line con 0
router(config-line)#login
router(config-line)#password password

Melihat Semua Konfigurasi
router#show running-config

Menghapus Semua Konfigurasi
router#erase startup-config
router#dir
router#delete flash:vlan.dat
router#dir
router#reload

setting password console dengan username

router(config)# username USER password WORD

router(config)# line console 0

routerconfig)# login local (local hanya jika ada username)

setting password telnet dengan username

router(config)# username USER password WORD

router(config)# line vty 0 4

routerconfig)# login local

setting encryption password

router(config)# service password encryptiton

setting banner

router(config)# banner metd # [enter]

pada akhir pesan diakhiri tanda #

atau

router(config)# banner exec # [enter]

pada akhir pesan diakhiri tanda #

Clear BGP

router# clear ip BGP [ ip address destination ] soft

Gambar Topology VLAN

Langkah-langkah di Catalyst Switch 1924:
Switch#config t
Switch(config)#vlan 10
Switch(config)#vlan 20
Switch(config)#interface e0/1
Switch(config-fi)#vlan-membership static 10
Switch(config-if)#interface e0/2
Switch(config-if)#vlan-membership static 10
Switch(config-if)#interface e0/4
Switch(config-if)#vlan-membership static 20
Switch(config-if)#interface e0/5
Switch(config-if)#vlan-membership static 20
Switch(config-if)#interface fastethernet0/26
Switch(config-if)#Trunk On
Switch(config-if)#exit
Switch(config)#ip default gateway 10.1.1.1
Switch(config)# ip add 10.1.1.2 255.255.255.0
Langkah-langkah di Router ICT:
Router-ICT(config)#interface f0/0
Router-ICT(config-if)#description Terhubung ke Switch
Router-ICT(config-if)#exit
Router-ICT(config)#interface f0/0.1
Router-ICT(config-subif)#ip address 10.1.1.1 255.255.255.0
Router-ICT(config-subif)#encapsulation ISL 1
Router-ICT(config-subif)#exit
Router-ICT(config)#interface fastethernet0/0.10
Router-ICT(config-subif)#encapsulation ISL 10
Router-ICT(config-subif)#ip address 10.22.77.130 255.255.255.0
Router-ICT(config-subif)#exit
Router-ICT(config)#interface fastethernet0/0.20
Router-ICT(config-subif)#encapsulation ISL 20
Router-ICT(config-subif)#ip address 192.168.0.1 255.255.255.0

Konfigurasi Cisco Catalyst

Posted: Agustus 20, 2010 in Cisco
Tag:, , ,

1. Apa sih Cisco Catalyst
Mungkin kalo ada temen yang belum tahu apa tuh Cisco Catalyst, kita bahas dulu bentar tentang Cisco Catalyst. Benda ini (Cisco Catalyst) adalah sebuah produk yang dikeluarkan oleh sebuah perusahaan bernama Cisco dan dinamakan Catalyst. Terdapat banyak tipe yang dikeluarkan oleh perusahaan ini. Tepatnya berapa ? Wah, gw sendiri nggak tau tuh. Tapi mempermasalahkan hal ini nggak ada gunanya. Yang penting adalah gimana makenya dan cara konfigurasinya.
2. Pemakaian Catalyst
Catalyst yang biasa gw oprek, kebanyakan dipake buat switch. Kalo Catalyst buat router, sampai hari ini belum pernah gw oprek. Paling ngeliat dari telnet doank. Tapi setahu gw dari pengalaman selama ini, kayaknya nggak jauh beda sama Catalyst buat switch.
3. Gimana Konfigurasinya
Oke, kita mulai aja pelajarannya. Buat mengkonfigurasi Catalyst, yang musti lo sediain adalah sebuah komputer, atau laptop dengan port COM, kabel Console, dan sebuah program Hyper Terminal. Kalo laptop yang lo punya nggak punya port COM, berarti lo musti punya kabel converter dari COM (db-9) ke USB.
Langkah selanjutnya adalah menghubungkan kabel Console ke port COM komputer dan port Console Catalyst. Tentunya komputer dan Catalyst harus udah terhubung ke power supply. Oke, selanjutnya buka hyper terminal. Pilih nama port yang dipake buat terhubung ke Catalyst. Bikin speed rate nya jadi 9600. Nah, Catalyst sudah siap di konfigurasi.
Setting Password
router>enable
router#configure terminal
router(config)#enable password password
router(config)#enable secret secret
Setting Host Name
router>enable
router#configure terminal
router(config)#hostname nama-host
Setting Vlan
router>enable
router#configure terminal
router(config)#vlan nomor-vlan
router(config-vlan)#name nama-vlan
Setting IP Address pada Vlan
router>enable
router#configure terminal
router(config)#interface vlan 1
router(config-if)#ip address address mask
router(config-if)#no shutdown
Setting Identitas pada Port
router>enable
router#configure terminal
router(config)#interface nama-port
router(config-if)#description “Uplink ke PPSI”
router(config-if)#end
Setting IP Gateway
router>enable
router#configure terminal
router(config)#ip default-gateway address
Setting Port-Speed dan Link-Mode
router#configure terminal
router(config)#interface nama-port
router(config-if)#speed 100
router(config-if)#duplex full
router#configure terminal
router(config)#interface nama-port
router(config-if)#switchport mode access
router(config-if)#switchport access vlan nama-vlan
router#configure terminal
router(config)#interface nama-port
router(config-if)#switchport mode trunk
router(config-if)#switchport trunk allowed vlan nama-vlan
Setting Line VTY
router#configure terminal
router(config)#line vty 0 4
router(config-line)#login
router(config-line)#password password
Setting Line Con 0
router#configure terminal
router(config)#line con 0
router(config-line)#login
router(config-line)#password password
Melihat Semua Konfigurasi
router#show running-config
Menghapus Semua Konfigurasi
router#erase startup-config
router#dir
router#delete flash:vlan.dat
router#dir
router#reload

Setup Cisco Catalyst 2960

Posted: Agustus 20, 2010 in Cisco
Tag:, , ,

C2960 Boot Loader (C2960-HBOOT-M) Version 12.2(25r)FX, RELEASE SOFTWARE (fc4)
Cisco WS-C2960-24TT (RC32300) processor (revision C0) with 21039K bytes of memory.
2960-24TT starting…
Base ethernet MAC Address: 0002.175C.B6D5
Xmodem file system is available.
Initializing Flash…
flashfs[0]: 1 files, 0 directories
flashfs[0]: 0 orphaned files, 0 orphaned directories
flashfs[0]: Total bytes: 64016384
flashfs[0]: Bytes used: 4414921
flashfs[0]: Bytes available: 59601463
flashfs[0]: flashfs fsck took 1 seconds.
…done Initializing Flash.

Boot Sector Filesystem (bs:) installed, fsid: 3
Parameter Block Filesystem (pb:) installed, fsid: 4

Loading “flash:/c2960-lanbase-mz.122-25.FX.bin”…
######################################### [OK]
Restricted Rights Legend

Use, duplication, or disclosure by the Government is
subject to restrictions as set forth in subparagraph
(c) of the Commercial Computer Software – Restricted
Rights clause at FAR sec. 52.227-19 and subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS sec. 252.227-7013.

cisco Systems, Inc.
170 West Tasman Drive
San Jose, California 95134-1706

Cisco IOS Software, C2960 Software (C2960-LANBASE-M), Version 12.2(25)FX, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2005 by Cisco Systems, Inc.
Compiled Wed 12-Oct-05 22:05 by pt_team
Image text-base: 0×80008098, data-base: 0×814129C4

Cisco WS-C2960-24TT (RC32300) processor (revision C0) with 21039K bytes of memory.

24 FastEthernet/IEEE 802.3 interface(s)
2 Gigabit Ethernet/IEEE 802.3 interface(s)

64K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address : 0002.175C.B6D5
Motherboard assembly number : 73-9832-06
Power supply part number : 341-0097-02
Motherboard serial number : FOC103248MJ
Power supply serial number : DCA102133JA
Model revision number : B0
Motherboard revision number : C0
Model number : WS-C2960-24TT
System serial number : FOC1033Z1EY
Top Assembly Part Number : 800-26671-02
Top Assembly Revision Number : B0
Version ID : V02
CLEI Code Number : COM3K00BRA
Hardware Board Revision Number : 0×01

Switch Ports Model SW Version SW Image
—— —– —– ———- ———-
* 1 26 WS-C2960-24TT 12.2 C2960-LANBASE-M

Cisco IOS Software, C2960 Software (C2960-LANBASE-M), Version 12.2(25)FX, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2005 by Cisco Systems, Inc.
Compiled Wed 12-Oct-05 22:05 by pt_team

Press RETURN to get started!

Switch>ena
Switch#s
Switch#se
Switch#setup
Switch#setup
Switch#setup ?

Switch#setup

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: yes

At any point you may enter a question mark ‘?’ for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets ‘[]‘.

Basic management setup configures only enough connectivity
for management of the system, extended setup will ask you
to configure each interface on the system

Would you like to enter basic management setup? [yes/no]: yes
Configuring global parameters:

Enter host name [Switch]: helmstandart

The enable secret is a password used to protect access to
privileged EXEC and configuration modes. This password, after
entered, becomes encrypted in the configuration.
Enter enable secret: rhino

The enable password is used when you do not specify an
enable secret password, with some older software versions, and
some boot images.
Enter enable password: rhino
% Please choose a password that is different from the enable secret
Enter enable password: cakep

The virtual terminal password is used to protect
access to the router over a network interface.
Enter virtual terminal password: cakep
Configure SNMP Network Management? [yes]:
% This version of Packet Tracer does not support SNMP management setup.
Configure SNMP Network Management? [yes]:yes
% This version of Packet Tracer does not support SNMP management setup.
Configure SNMP Network Management? [yes]:no
Configuring interface parameters:

Do you want to configure Vlan1 interface? [yes]:yes
Configure IP on this interface? [yes]: yes
IP address for this interface: 192.168.0.101
Subnet mask for this interface [255.255.255.0] : 255.255.255.0
Would you like to enable as a cluster command switch? [yes/no]:no

The following configuration command script was created:

!
hostname helmstandart
enable secret 5 $1$mERr$oU7khLPiPJy4.lkjTjSAT/
enable password cakep
line vty 0 4
password cakep
!
interface Vlan1
ip address 192.168.0.101 255.255.255.0
!
interface FastEthernet0/1
no ip address
!
interface FastEthernet0/2
no ip address
!
interface FastEthernet0/3
no ip address
!
interface FastEthernet0/4
no ip address
!
interface FastEthernet0/5
no ip address
!
interface FastEthernet0/6
no ip address
!
interface FastEthernet0/7
no ip address
!
interface FastEthernet0/8
no ip address
!
interface FastEthernet0/9
no ip address
!
interface FastEthernet0/10
no ip address
!
interface FastEthernet0/11
no ip address
!
interface FastEthernet0/12
no ip address
!
interface FastEthernet0/13
no ip address
!
interface FastEthernet0/14
no ip address
!
interface FastEthernet0/15
no ip address
!
interface FastEthernet0/16
no ip address
!
interface FastEthernet0/17
no ip address
!
interface FastEthernet0/18
no ip address
!
interface FastEthernet0/19
no ip address
!
interface FastEthernet0/20
no ip address
!
interface FastEthernet0/21
no ip address
!
interface FastEthernet0/22
no ip address
!
interface FastEthernet0/23
no ip address
!
interface FastEthernet0/24
no ip address
!
interface GigabitEthernet1/1
no ip address
!
interface GigabitEthernet1/2
no ip address
!
end

[0] Go to the IOS command prompt without saving this config.
[1] Return back to the setup without saving this config.
[2] Save this configuration to nvram and exit.

Enter your selection [2]: 2
Building configuration…
[OK]
Use the enabled mode ‘configure’ command to modify this configuration.

helmstandart#

Konfigurasi Cisco Catalyst Switch 2950

Anda dapat konek ke switch 2950 menggunakan kabel console. Dan masuk ke global konfigurasi

1.       Konfigurasi Hostname

Sama halnya dengan router gateway, switch bisa juga diberi hostname. Untuk memudahkan pengidentitasan bila mempunyai switch yang lebih dari satu. Untuk membuat hostname harus masuk ke menu console switch

switch>enable
switch#config terminal
Enter configuration commands, one per line.  End with CNTL/Z
switch(config)#hostname S_paidjo
S_paidjo(config)#exit
S_paidjo#

2.       Menyimpan dan Menghapus konfigurasi switch 2950

Untuk menyimpan konfigurasi diatas dengan cara:

S_paidjo#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
S_paidjo#

Untuk menghapus konfigurasi:

S_paidjo#erase startup-config
Erasing the nvram filesystem will remove all configuration files!
Continue? [confirm]
[OK]
Erase of nvram: complete
*Aug  1 12:45:11.134: %SYS-7-NV_BLOCK_INIT: Initialized the geometry of nvram
S_paidjo#

3.       Konfigurasi VLAN

Pada konfigurasi vlan ini ada dibagi untuk warnet adalah vlan 2 dan untuk gamenet vlan 3, untuk lebih mudahnya saya sertakan dengan 2 buah host pada vlan 2 (warnet) dan 2 host pada vlan 3 (gamenet), seperti gambar berikut:

Members Vlan IP Address
Host A Warnet 192.168.20.2
Host B Warnet 192.168.20.3
Host C Gamenet 192.168.30.2
Host D Gamenet 192.168.30.3

Langkah pertama membuat Vlan database yang terbagi menjadi dua

ID VLAN Members Port
Vlan 2 Warnet 2, 3
Vlan 3 gamenet 10, 11

Buat vlan member terlebih dahulu

S_paidjo>en
S_paidjo#vlan database
S_paidjo(vlan)#vlan 2 name Warnet
VLAN 2 modified:
Name: Warnet
S_paidjo(vlan)#vlan 3 name Gamenet
VLAN 3 modified:
Name: Gamenet
S_paidjo(vlan)#exit
APPLY completed.
Exiting....
S_paidjo(config)#exit
S_paidjo#sh vlan
VLAN Name                       Status    Ports
---- ------------------------- --------- -----------------------------
1    default                   active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                         Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                         Fa0/9, Fa0/10, Fa0/11, Fa0/12
2    Warnet                    active
3    Gamenet                   active
1002 fddi-default              active
1003 token-ring-default        active
1004 fddinet-default           active
1005 trnet-default             active

Sekarang konfigurasi vlan ke port masing-masing yang sudah dibagi

S_paidjo>en
S_paidjo#conf t
Enter configuration commands, one per line.  End with CNTL/Z
S_paidjo(config)#int f0/2
S_paidjo(config-if)#switchport access vlan 2
S_paidjo(config-if)#exit
S_paidjo(config)#int f0/3
S_paidjo(config-if)#switchport access vlan 2
S_paidjo(config-if)#exit
S_paidjo(config)#int f0/10
S_paidjo(config-if)#switchport access vlan 3
S_paidjo(config-if)#exit
S_paidjo(config)#int f0/11
S_paidjo(config-if)#switchport access vlan 3
S_paidjo(config-if)#exit
S_paidjo(config)#exit
S_paidjo#sh vlan
VLAN Name                     Status    Ports
---- ----------------------- --------- -------------------------------
1    default                  active    Fa0/1, Fa0/4, Fa0/5, Fa0/6
                                        Fa0/7, Fa0/8, Fa0/9, Fa0/12
2    Warnet                   active    Fa0/2, Fa0/3
3    Gamenet                  active    Fa0/10, Fa0/11
1002 fddi-default             active
1003 token-ring-default       active
1004 fddinet-default          active
1005 trnet-default            active